Problème avec Trigger Delete

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème avec Trigger Delete

Message  bexhausted le Lun 24 Juil 2017 - 23:47

EDIT: testé avec Activate et Spawn, ben ça marche sur une carte test Lapino ! Cependant j'ai une chaîne logique dans un autre groupe qui ne fonctionne pas et je ne comprends pas pourquoi ! Je vais tout reprendre à zéro dans ce cas précis.
J'ai retrouvé ce qui ne va pas avec le Trigger Delete et les véhicules : Delete efface les véhicules si la case Enable est cochée. Lorsque le véhicule est généré par un Activate (case Enable décochée) Delete ne fonctionne pas.
Le test suivant le montre. F12 pour se positionner devant un camion qui s'efface après destruction. Par contre le char ne répond pas au Delete.

avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  bexhausted le Mar 25 Juil 2017 - 10:29

J'ai compris ce qui se passe!

La chaîne est Véhicule (Vh) ->OnKilled/Ondamaged->Timer->Delete VH

J'ai supprimé le Timer et le Delete. Changé d'avis et comme j'avais ce groupe en mémoire j'ai importé la chaîne Timer->Delete. Relié le VH par OnKIlled/OnDamaged au nouveau Timer->Delete->Vh.
Marche pas !?
Je recrée complètement la chaîne Timer->Delete. Recrée tous les liens.
Marche pas !?
J'ouvre à nouveau la mission et je vais ouvrir directement les propriétés avancées du Vh avant de faire quoi que ce soit. Et là surprise il a gardé en mémoire dans la table d'évènements l'ID du premier Timer !
J'efface un à un tous les Events de chaque VH. Enregistre la mission. Ouvre à nouveau: dans les Adv Prop il n'y a plus rien. Je recrée tous les events et tous les liens. Relance.
Marche pas !?
Because l'ID du Timer initial est toujours conservé en mémoire !
Bien que le Timer recréé est une ID différente du Timer initial le VH conserve l'ID de celui-ci bien q'étant relié au nouveau Timer.

D'autre part, d'après mes observations il faut toujours créé l'Event OnKilled AVANT OnDamaged sinon ça ne marche pas.
avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  bexhausted le Mar 25 Juil 2017 - 10:38

J'ai essayé de me passer du Timer ...sans succès ! Le Vh conserve cette satané ID d'un Timer qui n'existe plus !
Une seule solution changer tous les Véhicules et ...recréer tous les liens !
:-((
avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  bexhausted le Mar 25 Juil 2017 - 16:34

CONCLUSION : la mission est corrompue !
J'ai recréé de toutes pièces les convois, relié à nouveau tout le monde.
Et le leader de chaque convoi reprend l'ID du leader initial (leader ID28, les nouveaux du même convoi 370 etc).
Pour contrôler j'ai ajouté un véhicule seul que j'active, détruis et efface sans problème !
Je fais une pause là !
avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  Pollux18 le Mar 25 Juil 2017 - 18:46

Je pige pas la moitié de ce que tu racontes a Phoenix mais lui à l'aire de te comprendre... :-}


J'admire ton implication ;-]
avatar
Pollux18
Mladishiy Leitienant
Mladishiy Leitienant

Messages : 592
Date d'inscription : 10/11/2012
Age : 42
Localisation : Centre de la France

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  bexhausted le Mar 25 Juil 2017 - 21:30

Cela à l'air compliqué mais c'est surtout une question de vocabulaire.
En fait c'est de l'obstination : en résumé j'ai deux choses qui fonctionnent parfaitement (testées et retestées) et quand je les mets ensemble il n'y en a qu'une partie qui fait ce que je lui demande.
Je n'y peux rien il y a un malin génie dans le truc qui fait tout foirer, je le sais je l'ai vu mais je n'ai pas les incantations pour le faire déguerpir !  Mais je suis têtu : j'efface tout et je recommence à zéro depuis une page blanche. La différence avec mon essai précédent c'est que je sais comment faire, donc ce n'est qu'une question de patience.
avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  Ploofy le Mer 26 Juil 2017 - 18:00

Pour le peu dont je me souvienne de l'éditeur de RoF c'était surtout une question de liaison d'enchainement des événements
Il y avait souvent des interactions entre événements, qui normalement n'étaient pas liés, qui faisaient foirer l'ensemble
avatar
Ploofy
Starshiy Leitienant
Starshiy Leitienant

Messages : 43
Date d'inscription : 03/06/2017
Age : 52
Localisation : Nice

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  bexhausted le Mer 26 Juil 2017 - 18:29

j'ai tout recommencer depuis le début et tout marche impeccable. Il faut dire que j'ai fait tant de ratures sur mon brouillon qu'il est presque logique qu'à la longue ça coince.
Par contre j'ai toujours un souci avec le DELETE.
Que ce soit en Spawner, Activate ou Enable s'il n'y a qu'un seul véhicule DELETE fonctionne parfaitement et chaque véhicule isolé est parfaitement effacé.
Mais lorsque l'on travaille avec un convoi donc avec un leader parfaitement identifié, quelle que soit la façon dont je m'y prenne seul le dernier véhicule du convoi est effacé, les autres restent obstinément à brûler pendant 8 longues minutes.
Infernal lorsque des convois doivent se suivre sur la même route.
Voici le test fait sur Lapino. En appuyant sur F12 vous  trouverez en face de vous, de la droite vers la gauche un véhicule Enable, de 3 véhicules créés en Activate (le leader étant à gauche) et enfin d'un Marder en Spawn. Tout le monde explose à tour de rôle et s'efface sauf le leader et le N°1 du convoi Activate. J'ai essayé trente mille combinaisons. Rien à faire. Si quelqu'un a une idée ?
 
EDIT Pour être complet j'ai ajouté un convoi en Enable avec une chaîne logique différente (une des nombreuses combinaisons essayées !) avec un constat identique : seul le dernier véhicule du convoi est effacé.
https://www.sugarsync.com/pf/D8818977_82798700_7534490
avatar
bexhausted
Maior
Maior

Messages : 974
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Problème avec Trigger Delete

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum