Débug de mission test "pour les nuls !"

Voir le sujet précédent Voir le sujet suivant Aller en bas

Débug de mission test "pour les nuls !"

Message  Pollux18 le Lun 26 Sep 2016 - 18:26

J'ouvre se post pour éviter de polluer celui sur les vidéos.

Nouvelle tentative pour créer un vol de JU52 du parking sur la carte Véliki Luki.  Je sais que dixit Foxy les IA ne sont pas doué pour le taxiage mais j'aimerais juste savoir s'il y a une erreur de ma pars dans cette mission. Mon leader IA se plante inéluctablement hors piste...  :pale:

Voila le lien: https://www.dropbox.com/s/9dc9nxur7j1viga/Test%20mission%20Pollux%20Veliki%20Luki.7z?dl=0

Ps: Je m’emmêle  encore un peu les pinceaux dans la création de groupe. Il m'arrive de créer des sous groupes dans un groupe involontairement... :roll:


Dernière édition par Pollux18 le Lun 26 Sep 2016 - 19:00, édité 1 fois
avatar
Pollux18
Mladishiy Leitienant
Mladishiy Leitienant

Messages : 503
Date d'inscription : 10/11/2012
Age : 42
Localisation : Centre de la France

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Foxy le Lun 26 Sep 2016 - 18:35

Moi je voudrai bien ... mais quand je clique sur le lien, je tombe sur une page ou il est écrit:
"Ce dossier est vide."

:lol!:
avatar
Foxy
Pilote_Officier
Pilote_Officier

Messages : 233
Date d'inscription : 16/08/2013
Localisation : 95

http://logbook-pb0.p.ht/

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Pollux18 le Lun 26 Sep 2016 - 19:06

Lien normalement corrigé dans le premier post... :oops:

Je rajoute de lien de la version 2 de cette mission ou les IA décollent du bout de piste. Tout fonctionne bien mais à l'atterrissage les avions ne rejoignent pas le parking mais coupent leurs moteurs sur la piste avant de disparaître. J'ai du rater encore un truc mais quoi... ?

https://www.dropbox.com/s/gztxjdpch7vye6a/Test%20mission%20Pollux%20VL%20V2.7z?dl=0
avatar
Pollux18
Mladishiy Leitienant
Mladishiy Leitienant

Messages : 503
Date d'inscription : 10/11/2012
Age : 42
Localisation : Centre de la France

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Foxy le Lun 26 Sep 2016 - 21:04

Alors tu ne nous as pas donner beaucoup d'infos, et je n'ai pas tester tes missions, mais voici mon analyse :

  • La première est très bien réalisée.
    Je n'ai pas vu d'erreur si ce n'est qui faudrait revoir le placement de ton airfield Drozdova.
    En effet, si tu fais edit chart, tu vas te rendre compte que le cheminement de taxi fera passer tout tes avions par cette icone avant de suivre les points de taxi. Du coup ton leader, après la mise en route, risque de percuter ses ailiers
    Solution: placer l'icone airfield en face du leader et redessinez le cheminement de taxi via le bouton edit chart (je n'ai pas encore fait de tuto sur ce sujet)
    version corrigée ici :
    https://www.dropbox.com/s/yafuacd84tya1x3/Test%20mission%20Pollux%20Veliki%20Luki%20corrected.7z?dl=0

  • Pour la seconde, bizarre qu'ils ne rejoignent pas le parking. Peut être est ce qu'il y a un conflit du fait qu'il y a deux airfield sur une seule base, essaye en supprimant le Isocha 4512
avatar
Foxy
Pilote_Officier
Pilote_Officier

Messages : 233
Date d'inscription : 16/08/2013
Localisation : 95

http://logbook-pb0.p.ht/

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Pollux18 le Mar 27 Sep 2016 - 19:08

Merci pour les retours.

Alors on continu,

Cette fois j'ai un soucis dans un convoi de camion entre le waypoint 5 et le final. Les camions sont sensé quitter la route principal pour prendre une route secondaire qui mène vers un aérodrome.

J'ai donc positionné mon waypoint 5 au dernier carrefour mais une fois atteint les véhicules ne suivent plus la route et vont tous droit a travers la compagne jusqu'au waypoint final.

Cela veut'il dire que les routes secondaires ne sont pas pris en compte ou qu'il faut activer autre chose ?

Le lien: https://www.dropbox.com/s/jgbhv7kz9hxb80u/Test%20mission%20Pollux%20Novosokolniki.7z?dl=0

Dsl pour toute ces questions mais j'aime bien comprendre.
avatar
Pollux18
Mladishiy Leitienant
Mladishiy Leitienant

Messages : 503
Date d'inscription : 10/11/2012
Age : 42
Localisation : Centre de la France

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Foxy le Mar 27 Sep 2016 - 20:40

Ne sois pas désolé Pollux, il n'y a pas de mal à se poser des questions :)
Alors déjà sois rassuré, il n'y a pas d'erreurs dans ta mission, ton convoi est correctement paramétrer :D

Je pense qu'en effet la route secondaire n'est pas prise en compte. Est ce que c'est le cas sur toute les map je ne sais pas et celle ci ayant été développé par un tiers ceci explique peut être cela !
Toujours est il que tu peux essayer de tricher en rajoutant tout un tas de waypoint pour cette section finale (entre le wpt 5 et 6) et voir comment ça réagit
avatar
Foxy
Pilote_Officier
Pilote_Officier

Messages : 233
Date d'inscription : 16/08/2013
Localisation : 95

http://logbook-pb0.p.ht/

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Pollux18 le Mar 27 Sep 2016 - 21:01

Ok merci j'essayerais avec plusieurs waypoints intermédiaire.
avatar
Pollux18
Mladishiy Leitienant
Mladishiy Leitienant

Messages : 503
Date d'inscription : 10/11/2012
Age : 42
Localisation : Centre de la France

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  bexhausted le Mer 28 Sep 2016 - 10:17

L'ajout de l'aérodrome de déroutement par Phoenix sur la Mission 01 et la vidéo de Foxy sur la Commande Behavior m'ont donné l'idée de créer un petit exo d'application conjuguant les deux.
Mais si je poste ici c'est que cela ne fonctionne pas comme prévu !

>>> Ce que je veux faire (test ici en mission solo donc il y a des choses que je ne peux vérifier )

Un avion nommé "il2m42player" endommagé rejoint une base neutre au démarrage de la mission qui s'active et devient russe  à l'approche d'un avion russe endommagé du même nom.
Si l'avion se pose correctement le Trigger Complex doit activer une commande ( Damage) Repair Complete. En même temps je veux voir si la commande (Damage) Repair Complete rétablit aussi la valeur initiale en carburant de mon avion qui était de 1 dans ses propriétés avancées. Au moment où je prends l'avion je pars avec 70 l de carburant.

>>> Schéma du groupe :


Comment cela devrait fonctionner
>Le Check Zone vérifie l'entrée d'un avion russe. Active un sous titre "Check Zone Actif" et Active le Trigger Complex. J'endommage volontairement mon avion pour que le Trigger Complex valide le filtre correspondant.
>Le Trigger Complex (active un sous titre "Trigger Complex actif " et ainsi de suite pour tous les ss/titres) est chargé de vérifier :
1- que l'avion est Russe "Country Russia", endommagé "ObjectDamaged" mais en vie "OnObjectEnteredAlive" . Il active alors la commande Behavior qui change la nationalité de l'Airfield en russe et ouvre le planeset #1 qui contient 10 IL2M42 (l'idée serait qu'en multiplayer le joueur puisse repartir de cette base avec un avion réparé refuelé et/ou réarmé ).
2-que l'avion est posé en vie "On ObjectStationaryAlive (c'est peut -être pas le bon test ?) et active alors la Commande Repair et le sous titre... que je ne vois jamais !

>>Les réglages de mon Trigger Complex



>>les réglages de la base de secours



Et le zip de mon groupe sur Lapino

https://www.dropbox.com/s/p1u24krifmioiyy/Yantar_D%C3%A9routement.7z?dl=0

:suspect:  ????
avatar
bexhausted
Maior
Maior

Messages : 897
Date d'inscription : 13/06/2015

Revenir en haut Aller en bas

Re: Débug de mission test "pour les nuls !"

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum